Stefan's Weblog

13Jun/150

Hyperlink mit VBA prüfen

Mit dem Makro lassen sich sehr einfach Hyperlinks in einer Excel-Tabelle prüfen, d.h. ist die verlinkte-Datei an diesem Ort zu finden.

Excel-Hyperlinks

Excel-Hyperlinks

Sub HyperlinkTest()
    Dim hLink As Hyperlink
    
    ' Prüft das aktive Arbeitsblatt und die Hyperlinks in Spalte 2
    With ActiveSheet.Columns(2)
        ' Schreibt den Erfolg der Prüfung in die Spalte Columns(x) + 3
        For Each hLink In .Hyperlinks
            .Cells(hLink.Range.Row, 3) = _
                IIf(Dir(hLink.Address) <> "", "OK", "nicht OK")
        Next
    End With
End Sub

26Feb/150

Kopf- und Fußzeile

Mit Hilfe von VBA lassen sich die Kopf- und Fußzeile sehr einfach und schnell befüllen.

22Feb/150

E-Mail via VBA aus Excel versenden

Mit Hilfe von VBA lässt sich sehr einfach eine Tabelle einer Arbeitsmappe als E-Mail versenden. Die Besonderheit hier, hat man mehrere Konten im Outlook angelegt, kann man mittels dem Parameter .Session.Accounts.Item das Absendekonto auswählen. Voraussetzung ist dafür natürlich das Recht, dass man auch von diesem Konto E-Mails versenden darf.

20Feb/150

Auswahlbox mit VBA erstellen

Eine Auswahlbox, wie man diese normal über Daten --> Datenüberprüfung erstellen kann, ist mit VBA ein wenig umständlicher zu erstellen.

Auswahl-Dropdown

Auswahl-Dropdown

20Feb/150

Nur bestimmte Werte in neues Tabellenblatt kopieren

In der Spalte A stehen die Werte 1 und 2. Es sollen aber nur die Werte 1 samt den Einträgen den Spalten B:E in das Tabellenblatt "Ziel" kopiert werden.

Quelle:

Excel VBA- Nur bestimmte Werte in neue Tabelle übertragen

Excel VBA- Nur bestimmte Werte in neue Tabelle übertragen

18Feb/150

Anzahl von Einträgen in einer Spalte ermitteln

In einer Spalte stehen unterschiedliche Werte, von denen einige doppelt aufgelistet werden. Man möchte aber die Anzahl der Einträge ermitteln, wobei die Doppelten nur als ein Eintrag gezählt werden sollen.

Excel VBA - Anzahl

Excel VBA - Anzahl

17Feb/150

Daten aus anderer Arbeitsmappe in aktuelle Tabelle kopieren


Ziel

Man möchte in die aktuell geöffnete Arbeitsmappe in eine bestimmte Tabelle Daten aus einer anderen, Arbeitsmappe aus einer definierten Tabelle kopieren.

Wir unterscheiden einfachheitshalber zwischen

  • Zielarbeitsmappe: Die geöffnete Arbeitsmappe, in die die Daten kopiert werden sollen
  • Quellarbeitsmappe: Die Arbeitsmappe, die die zu kopierenden Daten enthält.

2Jun/140

Excel – Letzte befüllte Zelle einer Spalte ermitteln

Mit der folgenden kleinen Formel lässt sich ganz einfach die letzte befüllte Zelle einer Spalte ermitteln.

=VERGLEICH(0;B3:B36;-1)

EXCEL - Letzte befüllte Zelle einer Spalte ermitteln

Letzte befüllte Zelle einer Spalte ermitteln

Eine Kombination mit einem SVERWEIS könnte so aussehen.
Es wird die letzte befüllte Zelle in der Nummernspalte ermittelt und dann das Ergebnis, das Datum, ausgegeben.
Die Formel in C2 hierfür lautet

=SVERWEIS(VERGLEICH(0;B3:B36;-1);B3:C36;2;0)

10Feb/141

Text in Zahlen umwandeln mit VBA

Text in Zahlen umwandeln - manuell

In einem meiner früheren Post habe ich bereits ein Makro hierfür gepostet ➡ Text in Zahlen umwandeln. Bei diesem Makro wird der zu formatierende Bereich dynamisch ermittelt. Es wird der Bereich A4 bis zu letzten beschriebenen Zelle in eine Zahl umgewandelt, anstatt dies manuell über den grünen Pfeil vorzunehmen, geht das bequem über das Makro.

23Okt/130

Excel – Forlaufende Nummerierung trotz leerer Zellen

Excel bietet eine einfache Möglichkeit, Zeilen zu nummerieren. Was macht man aber, wenn einige Zellen keine Werte enthalten oder einen anderen Inhalt haben und nicht mit in die Nummerierung mit einbezogen werden sollen?

Excel - ZÄHLENWENN

Excel - ZÄHLENWENN

Im Screenshot ist zu sehen, dass nur die Zellen die ein x enthalten in der Nummerierung berücksichtigt werden. Die leeren Zellen werden ignoriert.

Seiten: 1 2 3