Stefan's Weblog Blog über alle möglichen Dinge rund um den Computer

2Jun/140

Excel – Letzte befüllte Zelle einer Spalte ermitteln

Mit der folgenden kleinen Formel lässt sich ganz einfach die letzte befüllte Zelle einer Spalte ermitteln.

=VERGLEICH(0;B3:B36;-1)

EXCEL - Letzte befüllte Zelle einer Spalte ermitteln

Letzte befüllte Zelle einer Spalte ermitteln

Eine Kombination mit einem SVERWEIS könnte so aussehen.
Es wird die letzte befüllte Zelle in der Nummernspalte ermittelt und dann das Ergebnis, das Datum, ausgegeben.
Die Formel in C2 hierfür lautet

=SVERWEIS(VERGLEICH(0;B3:B36;-1);B3:C36;2;0)

10Feb/141

Text in Zahlen umwandeln mit VBA

Text in Zahlen umwandeln - manuell

In einem meiner früheren Post habe ich bereits ein Makro hierfür gepostet :arrow: Text in Zahlen umwandeln. Bei diesem Makro wird der zu formatierende Bereich dynamisch ermittelt. Es wird der Bereich A4 bis zu letzten beschriebenen Zelle in eine Zahl umgewandelt, anstatt dies manuell über den grünen Pfeil vorzunehmen, geht das bequem über das Makro.

23Okt/130

Excel – Forlaufende Nummerierung trotz leerer Zellen

Excel bietet eine einfache Möglichkeit, Zeilen zu nummerieren. Was macht man aber, wenn einige Zellen keine Werte enthalten oder einen anderen Inhalt haben und nicht mit in die Nummerierung mit einbezogen werden sollen?

Excel - ZÄHLENWENN

Excel - ZÄHLENWENN

Im Screenshot ist zu sehen, dass nur die Zellen die ein x enthalten in der Nummerierung berücksichtigt werden. Die leeren Zellen werden ignoriert.

14Aug/130

Tabellen nach einer Tabelle in eine Excel Arbeitsmappe einfügen

Das nachfolgende Makro kopiert die Tabelle CW1 und fügt diese nach einer definierten Tabelle in die bestehende Excel-Arbeitsmappe ein.

Der Name der neuen Tabelle beginnt mit einer fest definierten Buchstabenkombination die durch eine vom User eingegebenen Buchstaben oder Zahlenkombination ergänzt wird.

Der vom Benutzer eigegebenen Tabellenname wird zudem in der Zelle B7 ausgegeben.

24Apr/130

Fortschrittsbalken in Excel

Fortschrittsbalken, wie man sie z.B. in einer Projektmanagementsoftware findet, lassen sich auch sehr einfach in Excel erzeugen.

Fortschrittsbalken

Fortschrittsbalken

Im Screenshot ist der Fortshrittsbalken dargestellt, der den aktuellen Status der jeweiligen Aufgabe anzeigt. Mit Hilfe einer Excel-Formel lässt sich dies sehr einfach erstellen. In der Zelle E4 steht dies:

=WIEDERHOLEN("|";GANZZAHL((D4/$D$2)*100))


Im Grunde ist die Formel nichts weiter als eine Prozentberechnung, die grafisch aufbereitet wird.

11Apr/130

Navigation via ListBox in einer Excel Arbeitsmappe

Navigation für Excel Arbeitsmappe

Mit Hilfe eines Listenfelds (ListBox) kann man sehr einfach eine Navigation innerhalb einer Excel-Arbeitsmappe erstellen.

Die Navigation soll folgende Funktionen beinhalten

  • Bei jedem Öffnen der Arbeitsmappe sol sich die Navigation dynamisch füllen, je nach Anzahl und Benennung der einzelnen Tabs innerhalb der Arbeitsmappe
5Apr/130

Tabellen in einer Arbeitsmappe aufsteigend nummerieren

Innerhalb einer Excel Arbeitsmappen kann man die einzelnen Tabellen fortlaufend nummerieren lassen.

Das Makro dafür lautet:

Sub Nummerierung()
    Dim i As Long
    For i = 1 To Sheets.Count
    Sheets(i).Name = "CW" & i '+ 1
    Next
End Sub

Innerhalb des Codes ist CW durch den von euch gewünschten Namen zu ersetzen.

28Mrz/130

Mit Drefeldern die Tabellenblätter durchblättern

Mit Hilfe von Drefeldern kann man ganz enfach die Tabellenblätter einer Excel Arbeitsmappe drchschalten.

Drehfelder in Excel

Drehfelder in Excel

Der Code dazu ist kinderleicht:

Private Sub SpinButton1_SpinDown()
    ActiveSheet.Previous.Select
End Sub

Private Sub SpinButton1_SpinUp()
    ActiveSheet.Next.Select
End Sub

25Mrz/130

Datum aus Kalenderwoche ermitteln

Manchmal ist es ganz hilfreich, wenn man ausgehend von einer Kalenderwoche das Datum für einen definierten Tag in dieser ermitteln kann. Eine kleine Excel Formel kann das:

=DATUM(g1;1;1)+(g2-WENN(WOCHENTAG(DATUM(g1;1;1);2)>4;0;1))*7+g3-1+1-WOCHENTAG(DATUM(g1;1;1)+(g2-WENN(WOCHENTAG(DATUM(g1;1;1);2)>4;0;1))*7;2)

Hier die Erklärung zur Formel:

Datum aus Kalenderwoche ermitteln

Datum aus Kalenderwoche ermitteln

24Mrz/130

Bereiche innerhalb einer Tabelle mit einem Faktor multiplizieren

In diesem Beispiel möchten wir Werte in definierten Bereichen mehrerer Tabellen einer Arbeitsmappe und mit einem Faktor multiplizieren.

Anforderungen:

  • Die Faktor steht in jeder Tabelle in der gleichen Zelle. In unserem Beispiel ist das "C4"
  • Die Anzahl der Tabellen kann variieren.
  • Der Werte in dem Bereich, den wir mit dem Faktor multiplizieren möchten, ist in jeder Tabelle gleich.

Die Tabelle sieht in unserem Beispiel folgendermaßen aus:

Excel - Werte Tabellen übergreifend multiplizieren

Excel - Werte Tabellen übergreifend multiplizieren

Seiten: 1 2