INDEX & VERGLEICH – Alternative zum SVERWEIS

Die Index-Funktion in Excel kann verwendet werden, wenn der SVERWEIS an seine Grenzen stößt. Mit eine Kombination aus INDEX- und VERGLEICH-Funktion kann sowohl von links nach rechts, als auch von oben nach unten und in umgekehrter Reihenfolge gesucht werden.

INDEX

Mit der INDEX-Funktion haben wir die Möglichkeit innerhalb eines definierten Bereichs, einer sog. Matrix, nach einer Übereinstimmung zu suchen.
Im Beispiel lassen wir die Formel nach dem Wert 2 suchen und bei einem Treffer den Wert aus der Spalte 3 ausgeben.

INDEX-Funktion
INDEX-Funktion

Formel

=INDEX(B3:E12;2;3)

Zusammensetzung der Formel

  • Definition der Matrix = B3:E12
  • Suchkriterium = 2
  • Ausgabe = Spalte 3

VERGLEICH

Diese Formel erlaubt es uns nach einem Wert zu suchen und die relative Zeilennummer ausgeben zu lassen.
Der ermittelte Wert resultiert daher, dass der Wert 2 in der zweiten Zeile unserer definierten Matrix steht.

VERGLEICH-Funktion
VERGLEICH-Funktion

Formel

=VERGLEICH(2;B3:B12;0)

Zusammensetzung der Formel

  • Suchkriterium = 2
  • Definition der Matrix = B3:B12
  • Vergleichstyp = 0 “genaue Übereinstimmung”

Kombination INDEX- & VERGLEICH

Nun kombinieren wir die beiden Formeln, jedoch wird das Ergebnis aus Spalte 4 als gesuchter Wert ausgegeben.

INDEX- und VERGLEICH-Funktion
INDEX- und VERGLEICH-Funktion

Formel

=INDEX(B3:E12;VERGLEICH(2;B3:B12);4)

Beispiel-Datei zum herunterladen

INDEX & VERGLEICH - Alternative zum SVERWEIS




Bestseller Nr. 1
Excel 2019 - Das umfassende Kompendium. Komplett in Farbe. Grundlagen, Praxis, Formeln, VBA, Diagramme und viele praktische Beispiele: Auch für Office 365
  • Ignatz, Schels (Autor)
  • 704 Seiten - 12.07.2019 (Veröffentlichungsdatum) - Markt + Technik Verlag (Herausgeber)

(**) Produktpreise und -verfügbarkeit sind zum angegebenen Datum / Uhrzeit korrekt und können sich ändern. Alle Preis- und Verfügbarkeitsinformationen auf https://www.amazon.de/ zum Zeitpunkt des Kaufs gelten für den Kauf dieses Produkts.

2 Antworten auf „INDEX & VERGLEICH – Alternative zum SVERWEIS“

  1. In diesem Zusammenhang solltest du die Formel “Summenprodukt” nicht unterschlagen. 🙂
    Wenn der Wert in der “Suchspalte nur 1x vorkommt” ist´s eine Alternative zum SVerweis.
    Ist zwar für diese Funktion fast übertrieben, aber eben erweiterbar. 🙂

    Grüße

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.