Nextcloud Update 20.0.6 – Alle Lesezeichen nach Update weg!

Ich habe gerade das Update auf die neuste Version von Nextcloud auf 20.0.6 durchgeführt. Das Ganze lief wie gewohnt ohne Probleme durch und über die Weboberfläche und den Nextcloud-Client konnte ich auf die Daten zugreifen.

Nach einem Blick in die Lesezeichen meines Browsers war ich ein wenig schockiert. Es waren sämtliche Lesezeichen weg, nur meine Ordner waren noch da. Ich synchronisieren meine sämtlichen Bookmarks von meinen genutzten Webbrowsern und meinen mobilen Endgeräten über die Nextcloud, wie hier in meinem Beitrag beschrieben.
Lesezeichen über die Nextcloud synchronisieren

Bis vor dem Update hat die Kommunikation zwischen den Clients und der Nextcloud wunderbar funktioniert und die Bookmarks wurden alle immer zuverlässig übertragen.

Anzeige/Werbung

Ich habe auf meiner Nextcloud die Log-Funktion ausgeschaltet, da ich auf meinem Raspberry Pi die SD-Karte durch das zusätzliche Schrieben der Protokolle entlasten wollte. Deshalb ist es von mir eine Vermutung, dass das Update von Nextcloud und die neueste Version und die Lesezeichensynchronisation ein Problem verursachen könnte.

Ich hatte zum Glück ein aktuelles Backup meiner Lesezeichen, die ich über einen aktuellen Mozilla Firefox wieder in den Sync auf die Nextcloud eingespielt habe. Die Übertragung hat dann auch anstandslos funktioniert und ich konnte die Lesezeichen auch wieder in den anderen Browsern und auch auf meinen mobilen Endgeräten nutzen.

Also erstellt zur Sicherheit unbedingt ein Backup eurer Lesezeichen / Bookmarks bevor ihr auf die Version 20.0.6 von Nextcloud aktualisiert!

Nutzt ihr den Mozilla Firefox, dann könnt ihr ggf. auch von dort eure Lesezeichen wieder herstellen.

Dazu geht ihr wie folgt vor

Mozilla Firefox - Lesezeichen aufrufen

Bild 2 von 4

Mozilla Firefox - Lesezeichen aufrufen

Auf der Seite von Mozilla findet ihr eine ausführlichere Beschreibung
https://support.mozilla.org/de/kb/Verlorene-Lesezeichen

11 Antworten auf „Nextcloud Update 20.0.6 – Alle Lesezeichen nach Update weg!“

  1. Hallo Stefan,
    wieder ein gelungener Beitrag.
    Da ich in der Materie (Raspi und Nextcloud) ein kompletter Neuling bin, habe ich zum Update noch ein paar Fragen:
    Habe letzte Woche von 20.0.4 auf 20.0.5 upgedatet. Das Update lief über 43 Stunden. Ist das normal?
    Vor dem Update war die Nextcloud Pfeilschnell. Ich war wirklich begeistert. Nach dem Update bewegt sich überhaupt nichts mehr. Zum Beispiel der Wechsel ins App-Verzeichnis dauert über 3 Stunden. Was läuft da schief?
    Momentan update ich auf 20.0.6, in der Hoffnung, dass dann Nextcloud wieder normal funktioniert. Beim Punkt ‘Create backup’ werkt es schon wieder länger als 24 Stunden.
    Wie bekomme ich das in den Griff.

    Background:
    Raspberry Pi 4B mit 8GB RAM, 128 GB SD-Card
    Nextcloud ‘data’ auf einem 4TB USB 3.0 RAID 1 Laufwerk
    Nextcloud Installation so wie in Deinem Blog beschrieben.

    Über jede Hilfe oder Anregung wär ich außerordentlich dankbar.

    1. Hallo Eugen,

      das Verhalten ist sehr ungewöhnlich!

      Ich verwende den gleichen RPi wie du und da dauert das Update so zwischen 5 und 10 Minuten, je nach Release-Größe.

      Werden dir irgendwelche Fehlermeldungen in der Administrationsoberfläche von Nextcloud ausgegeben?
      Gibt es da evtl. einen Hinweis auf das Problem?

      Ich denke um ein wenig Recherche im den Log Files wirst du der Ursache nicht auf die Ursache deines Problems kommen.

      Mach doch mal folgendes:

      Mach ein Update von dem RaspberryPiOS

      Schau mal in den Log Files unter /var/log/ in den system Logs und in den Protokolldateien von deinem Webserver

      Aktiviere das Log für deine Nextcloud, wie hier beschrieben:
      https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/logging_configuration.html

      Eine weitere Idee habe ich momentan auch nicht.

      Grüße

      Stefan

      1. Hallo Stefan, danke für die Antwort.
        Die Log’s bin ich schon durchgegangen. Soweit ich das interpretieren kann, gibt es keine Auffälligkeiten.
        Da ich noch einen Raspi rumliegen habe, werde ich, sobald ich dazu komme, auf diesem eine Installation versuchen.

        1. Hallo Eugen,

          schau doch mal nach, ob es evtl. deine SD-Karte von deinem RPi erwischt hat.
          Gibt es irgendwelche Einschränkungen beim Zugriff per SSH auf deinen Server?

          Grüße

          Stefan

          1. Hallo Stefan,
            auf das habe ich ursprünglich getippt. Meines Erachtens funktioniert die problemlos. Vor dem Update hatte ich ein Image von der SD-Karte gemacht und auf eine Andere Karte gespielt – Das Verhalten ist das gleiche – vor dem Update funktioniert alles ganz normal, das Update läuft dann gut 2 Tage und nach dem Update rührt sich dann nichts mehr. Logfiles sehen alle OK aus.

            LG
            Eugen

    2. Ich hatte in ähnliches Verhalten mal, nachdem ich eine zusätzliche App installiert hatte. Kann mich aber gerade nicht mehr daran erinnern welche das war. Habe ich dann schnellstmöglich wieder runter geschmissen.

      Also hast du vll. in letzter Zeit eine App installiert, die das System blockieren könnte? Vll. irgendwas zum Bearbeiten von Office-Dokumenten?

  2. Na toll,
    mir ist genau das gleiche passiert. Nur dass ich natürlich kein Backup meiner Bookmarks habe. Zumindest nicht in der Form wie du.

    Aber weiß jemand vll. ob ich aus einem Daten-Backup die Bookmarks wiederherstellen kann? Welchen Ordner aus dem Daten-Ordner müsste ich wiedherstellen, um die Bookmarks zurück zu bekommen? Oder ist das gar nicht so einfach?

    1. Hallo Marcel,

      das ist sehr unschön!

      Die Lesezeichen werden wahrscheinlich in der Datenbank verwaltet.
      Vielleicht kannst du die von da irgendwie wieder herstellen.
      Schau dir mal diesen Post an, vielleicht hilft dir der:

      https://help.nextcloud.com/t/how-to-restore-lost-bookmarks-from-a-backup/51919/5

      Am Ende gibt es einen Verweis auf den Firefox, dass der die Lesezeichen auch archiviert.
      Schau mal, ob das bei dir auch zutrifft und du evtl. über den Weg an deine Lesezeichen herankommst.

      https://support.mozilla.org/de/kb/Verlorene-Lesezeichen

      Grüße

      Stefan

      1. Vielen Dank für deine schnelle Antwort.
        Habe es über die Wiederherstellungs-Funktion des Firefox gemacht. Hat perfekt geklappt. Jetzt funktioniert wieder alles wie gewohnt …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.