Let´s Encrypt – Problem binding to port 80: Could not bind to IPv4 or IPv6.

Nach 90 Tagen war es mal wieder soweit, mein Let´s Encrypt Zertifikat für meine Nextcloud wäre innerhalb von 1 Tag abgelaufen. Die Zeit drängte also eine Erneuerung zu starten. Also habe ich in meinem Beitrag ➡ Let’s Encrypt – Zertifikatserneuerung schlägt fehlt“ gespicket und nach dem richtigen Befehl dafür nachgeschlagen.

Leider habe ich jedesmal diesen Fehler erhalten, der mich schier zum Verzweifeln gebracht hat.

Problem binding to port 80: Could not bind to IPv4 or IPv6.

Ich habe daraufhin die gesamte Konfiguration meines Apache-Webservers kontrolliert, jedoch immer ohne Erfolg.

Zum Schluß war die Lösung ganz einfach. Es genügte ein Blick in die Konfiguration meines AVM-Routers. Dort war der Port 80, der für die Erneuerung des Let´s Encrypt Zertifikats zwingend erforderlich ist, nicht geöffnet. Nach einer Anpassung sieht die Konfiguration dort so aus:

Let´s Encrypt - Problem binding to port 80: Could not bind to IPv4 or IPv6.
Let´s Encrypt – Problem binding to port 80: Could not bind to IPv4 or IPv6.

Anschließend hat die Erneuerung des Zertifikats wunderbar geklappt:

Let´s Encrypt - Problem binding to port 80: Could not bind to IPv4 or IPv6.
Let´s Encrypt – Problem binding to port 80: Could not bind to IPv4 or IPv6.

Hier nochmal die Befehle, die zum Erfolg geführt haben:

sudo service apache2 stop
sudo /etc/letsencrypt/letsencrypt-auto certonly --dry-run --agree-tos --renew-by-default -a webroot --webroot-path /var/www/html/ -d mydyndns.dns.de
sudo service apache2 start

Nutzt den Befehl –dry-run solange, bis euch eine positives Ergebnis ausgegeben wird.

2 Antworten auf „Let´s Encrypt – Problem binding to port 80: Could not bind to IPv4 or IPv6.“

  1. Hallo Stefan,

    ich betreibe auf meinem RPi sowohl einen OpenVPN-Server, Nextcloud und das pi-hole. Als Backup für udp bei ovpn habe ich eine zweite Instanz mit tcp auf Port 443 laufen. Nun will Let’s Encrypt zwingend über Port 443 für die Erneuerung eines Zertifikates zugreifen.Hättest du eine Idee wie ich dieses Problem lösen könnte?

    Gruß

    Martin

  2. Hallo Martin,

    Sorry, da habe ich leider keine Erfahrung.
    Bei mir war das Problem anderes, Let´s Encrypt brauchte zwingend den Port 80 für die Aktualisierung der Zertifikats. Der Port 443 war dafür leider nicht geeignet.

    Grüße

    Stefan

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.