Stefan's Weblog

1Dez/152

INDEX & VERGLEICH – Alternative zum SVERWEIS

Die Index-Funktion in Excel kann verwendet werden, wenn der SVERWEIS an seine Grenzen stößt. Mit eine Kombination aus INDEX- und VERGLEICH-Funktion kann sowohl von links nach rechts, als auch von oben nach unten und in umgekehrter Reihenfolge gesucht werden.

INDEX

Mit der INDEX-Funktion haben wir die Möglichkeit innerhalb eines definierten Bereichs, einer sog. Matrix, nach einer Übereinstimmung zu suchen.
Im Beispiel lassen wir die Formel nach dem Wert 2 suchen und bei einem Treffer den Wert aus der Spalte 3 ausgeben.

INDEX-Funktion

INDEX-Funktion

Formel

=INDEX(B3:E12;2;3)

Zusammensetzung der Formel

  • Definition der Matrix = B3:E12
  • Suchkriterium = 2
  • Ausgabe = Spalte 3

VERGLEICH

Diese Formel erlaubt es uns nach einem Wert zu suchen und die relative Zeilennummer ausgeben zu lassen.
Der ermittelte Wert resultiert daher, dass der Wert 2 in der zweiten Zeile unserer definierten Matrix steht.

VERGLEICH-Funktion

VERGLEICH-Funktion

Formel

=VERGLEICH(2;B3:B12;0)

Zusammensetzung der Formel

  • Suchkriterium = 2
  • Definition der Matrix = B3:B12
  • Vergleichstyp = 0 "genaue Übereinstimmung"

Kombination INDEX- & VERGLEICH

Nun kombinieren wir die beiden Formeln, jedoch wird das Ergebnis aus Spalte 4 als gesuchter Wert ausgegeben.

INDEX- und VERGLEICH-Funktion

INDEX- und VERGLEICH-Funktion

Formel

=INDEX(B3:E12;VERGLEICH(2;B3:B12);4)

Beispiel-Datei zum herunterladen

Beispiel-Datei - Index_Vergleich

hat dir dieser Artikel gefallen?

Dann abonniere doch diesen Blog per RSS Feed!

Kommentare (2) Trackbacks (0)
  1. In diesem Zusammenhang solltest du die Formel „Summenprodukt“ nicht unterschlagen. 🙂
    Wenn der Wert in der „Suchspalte nur 1x vorkommt“ ist´s eine Alternative zum SVerweis.
    Ist zwar für diese Funktion fast übertrieben, aber eben erweiterbar. 🙂

    Grüße

  2. Hi,

    vielen Dank für den Hinweis. Werde mir das mal anschauen 🙂


Leave a comment

Noch keine Trackbacks.

%d Bloggern gefällt das: