Stefan's Weblog

21Jul/1655

motioneyeos – Überwachungskamera mit dem Raspberry ganz einfach

Einer der häufigeren Einsatzgebiete des Raspberry Pis ist wahrscheinlich die Verwendung als Überwachungskamera.
Dabei wird meistens Raspbian und das kleine Tool motion verwendet um aus dem Pi eine Überwachungskamera zu basteln. Je nach Erfahrung des Benutzers kann die Konfiguration ein wenig Zeit und auch Nerven in Anspruch nehmen. Mit der neuen Raspbian Version Jessie vielleicht ein wenig mehr als zuvor. Ich bin selbst ein wenig Leid geprüft, was das betrifft 🙂 Hier m Blog habe ich einige Anleitungen zu diesem Thema verfasst.

Aber es gibt auch eine weitaus einfacher und schnellere Möglichkeit, um aus dem kleinen Pi eine Überwachungskamera zu machen. An der Hardware ändert sich nichts, der entscheidene Unterschied, es wird ein speziell für diesen Einsatzzweck entwickeltes Betriebssystem verwendet.
Das Betriebssystem nennt sich motioneyeos und kann von der offiziellen github-Seite für jedes Pi-Modell heruntergeladen werden. ( ➡ https://github.com/ccrisan/motioneyeos/releases)

motioneyeos ist eine sehr abgespecketes Betriebssystem, dass nur dazu dient den Raspberry Pi auf ganz einfache Weise in eine Überwachungskamera zu verwandeln.
Die Installation ist denkbar einfach, das Image von der offiziellen Seite herunterladen und mit einem Tool, z.B. Win32DiskImager, auf die SD-Karte schreiben.

Anschließend steckt ihr die SD-Karte in euren Pi, verbindet diesen mit einem LAN-Kabel mit eurem Netzwerk und zum Schluß noch an den Strom anschließen.
Nun ein paar Minuten warten, bis motioneyeos Installiert wird und dann könnt ihr über einen beliebigen Webbrowser die Administrationsoberfläche öffnen.
Dazu gebt ihr lediglich die IP-Adresse des Pis ein, und schon gehts los.
Die Installationsanleitung gibt es auch im offiziellen Wiki des Projekts ➡ https://github.com/ccrisan/motioneyeos/wiki/Installation

Nach der sehr einfachen Installation und der ersten Anmeldung gelangt ihr auf die sehr aufgeräumte Konfigurationsseite eurer neuen Überwachungskamera.

motioneyeos

motioneyeos

Die Konfiurationsmöglichkeiten sind sehr gut in einzelne Abschnitte strukturiert und können jederzeit über den Webbrowser administriert werden.

Als erstes solltet ihr im Reiter "General Settings" das Passwort für den Administrator und auch die Zeitzone anpassen.

motioneyeos - General Settings

motioneyeos - General Settings

Weitere Einstellungen, die als danach zu prüfen und ggfs. anzupassen sind, sind

  • Network - falls ihr WLAN auf dem Pi verwenden möchtet
  • Services - Remotezugriffe einrichten
motioneyeos - Network & Services

motioneyeos - Network & Services

Im Abschnitt "Video Streaming" wird eingestellt, wie man Zugriff auf das Lievebild des Pi erhält.

motioneyeos - Video Streaming

motioneyeos - Video Streaming

Sämtliche anderen Einstellungen sind gut beschrieben, ansonsten gibt es für jede Konfigurationsmöglichkeit eine kleine Hilfe wie im Screenshot dargestellt.

motioneyeos - Hilfe

motioneyeos - Hilfe

Ich habe an den Pi zum Speichern der Bilder und Videos einen externen Datenträger (USB-Stick) angeschlossen
motioneyeos erkennt den Stick normalerweise automatisch und im Berech "File Storage" lässt sich dieser einbinden.

motioneyeos - File Storage

motioneyeos - File Storage

Ein weiteres tolles und gut gelungenes Feature von motioneyeos ist das Einbinden mehrer motioneyeos-Installation. Betreibt man mehrere Überwachungskameras im Netzwerk kann man diese in einer "Haupt"-Installation zusammen fassen. Änderungen müssen dann nicht auf jedem Pi durchgeführt werden, sondern können von der einen "Haupt-"Installation durchgeführt werden.

motioneyeos

motioneyeos

Mein Fazit:
Super gelungenes System, dass genau das erfüllt was es verspricht. Eine Möglichkeit einfach und schnell aus einem Pi eine Überwachungskamera zu machen.

Bildquelle: raspberrypi.org

hat dir dieser Artikel gefallen?

Dann abonniere doch diesen Blog per RSS Feed!

Kommentare (55) Trackbacks (0)
  1. Ich komme nicht weiter.
    Es wird nach login:
    und Password gefragt

  2. Hi Günter,

    der Benutzername ist admin und es ist kein Passwort vergeben. Das kannst du nach der erstmaligen Anmeldung dann im Adminmenü anlegen.

    Hoffe das hilft dir weiter.

    Stefan

  3. Hallo Stefan,
    Danke für die schnelle Antwort.
    Bei mir funktioniert es so nicht.
    Der Raspi startet mit dem Betriebssystem Motioneyeos für den Raps 3 Stand Febr. 2017.
    Er arbeitet einige Punkte ab, z.B. IP Adresse, Gateway, DNS Server Adresse.
    Dann kommt die Zeilen:
    Welcome to meye-8a4fe7a0!
    meye-8a4fe7a0 login: (hier ist eine Eingabe erforderlich z.B. admin) dann kommt die
    Zeile
    Password: (hier ist eine Eingabe erforderlich z. B. Leertaste) wenn keine Eingabe
    kommt nach 60 Sekunden wieder die Login-Zeile.

    Vielleicht kannst Du mir nochmals weiterhelfen ggf kann ich dich ja anrufen.
    Mit freundlichem Gruß- Günter Eich, Moers

  4. Hallo Günter,

    jetzt hat die Antwort ein wenig länger gedauert.

    Das Verhalten ist komisch. Normalerweise solltest du als Benutzername „admin“ eingeben, das Passwort leerlassen und dann kommst du auf die Benutzeroberfläche.

    So steht es auch im Wiki:
    „Click on the key icon on the upper-left side of the page to switch user to administrator. Use admin with no password when asked for credentials. Feel free to explore all the available configuration options.“ (Quelle: https://github.com/ccrisan/motioneyeos/wiki/Installation)

    Hast du es nochmal versucht?
    Hat es dann funktioniert?

    Grüße

    Stefan

  5. Hallo Stefan,
    vorab, ich habe es ans laufen bekommen.
    Ich habe alles mögliche versucht, leider ohne Erfolg.
    Dann aber, es gibt den Hinweis “ im Browser die Adresse der Kamera aufzurufen mit
    :80″ dann ging alles wie von selbst. Super deine Ausführungen, man muß nur
    genauer lesen können.
    Insgesamt hier nochmal ein Lob.
    Deine Ausführungen in Bezug auf die Raspicamera sind alle super, habe schon mehreres versucht, hat immer funktioniert. Hier nochmals ein Dank an Dich, mach weiter so.
    Viele Grüße- Günter

  6. Hallo Stefan, kann man Motioneyeos auch aus dem externen Netzwerk abrufen? Wenn ja wie kann ich das bewerkstelligen?

  7. Hallo Mario,

    das musst du über deinen Router konfigurieren.
    Mit MotionEyeOS alleine kannst du das nicht machen.

    Grüße

    Stefan

  8. Hallo.

    Bekomme leider keine Ip Camera ans laufen. ( Foscam , Xiaomi ).
    Bitte um Hilfe

  9. Foscam am laufen. Rtsp stream .rtsp://IP:Port/videoMain

  10. Nette Anleitung, aber gibt es irgendwo auch eine verständliche Anleitung, WIE die einzelen Punkte einzurichten sind? Die suche ich aktuell noch vergeblich.

    So richtig interessant wird es ja erst, wenn man z.B: den Punkt Motion Dection ins Spiel bringt. Aber genau hier habe ich Probelem. Entweder bekomme ich ständig in Intervallen Einzelbilder auf meine NAS (ich nutze einen Netzwerkspeicher) oder es werden Videos erzeugt, bei denen nirgendwo eine „Motion“ zu erkennen ist. Klappt es dann doch ausnahmsweise (ich selbst renne durchs Bild und mal gehts, mal nicht) dann bricht die Aufnahme unvermittelt ab, im schlimmsten Fall BEVOR genau das passiert, was ich eigentlich aufnehmen will. Aktuell lasse ich meine 4 Cams so laufen, was aber (bei einer Auflösun, in der man auch Gesicher erkennen kann) jeden tag zig GB an unbrauchbaren Daten produziert…

  11. Hallo Max,

    das kann ich nicht bestätigen. Meine Kameras nehmen Bewegungen auf (Bilder / Videos) und speichern das auch tadellos ab.

    Welche Hardware hast du genau?
    * Raspberry Pi
    * Kamera
    * etc.

    Hast du deine Motion-Einstellungen amgepasst?

    Grüße

    Stefan

  12. Kann man das Programm auch für den Zero mit Kamera-Anschluss benutzen?

    Gruß Werner Kick

  13. Benutze den Zero W und das BS motioneyeos-raspberrypi-20170827.img.gz
    Leider klappt es nur eingeschränkt. Datum und Uhrzeit wird nicht gesetzt. Wollte das unter Anderem mit Putty ändern. Da scheint aber einiges nicht zu gehen. So wird apt-get zB. nicht erkannt. Kann ich auch das motioneyeos-raspberrypi2 BS benutzen oder gibt es da eine bessere Alternative für den Zero?
    Gibt es eine deutsche Anleitung für das Programm?
    Die Performance er Kamera bzw Übertragung ist nicht sehr hoch. Vermute das liegt an dem Zero mit seinem alten Prozessor.

  14. Hallo Burkhard,

    vielen Dank.
    Bisher habe ich noch keine Erfahrung mit dem Zero.
    Vielleicht funktioniert auch das neue Debian-Derivat und du installiert Motion manuell.
    Motion zu konfigurieren ist nicht sehr.schwer, das geht einfach über ein Skript.

    Grüße

    Stefan

  15. Hallo, es Funktioniert sehr gut.
    Noch Dyndns und es wäre Top.
    Schöne Software.

  16. Hallo, es gibt bei motion Funktion, womit man Kommandos realisieren kann.

    Weißt jemand vielleicht welche Kommando ich da eintragen kann, damit bei einer Bewegung mit Hilfe der Kommando auf einem anderen app z.b linphone ein popup Fenster aufgeht mit Video-Darstellung ?

  17. Hallo alle, ich habe mit dem Raspberry Pi Zero erfahrungen machen können:
    Die rechenleistung reicht aus, um das Gerät zu betreiben. Allerdings darf man hier keine HD-Videos erwarten. Zum 3D-Drucker „beobachten“ reicht es aber allemal.
    Vorallem bin ich über Preis/Leistung beeindruckt. ein Neuer Raspi Zero W kostet bei Pimoroni keine 14,- € eine billige Cam gibts für unter 5 € in der Bucht ( China) und die Möglichkeiten scheinen schier unbegrenzt. Das Gerät ist dazu noch Winzig und sparsam im Stromverbrauch. Das „grösste“ ist die Powerbank 🙂
    Wer mehr Leistung will, greift zum Raspberry Pi3 und einer ordentlichen Kammera. Schade ist: Die praktische, „Beiligende“ Anleitung ist nur in Engisch und bereiten mir Probleme bei den „Feineinstellungen“.
    Frage: Hilft es dem Pi, wenn man den Codec Freischaltet, damit er sich bei höheren Auflösungen nicht mehr so abrackern muss ?
    Welche Cammeras könnt Ihr empfehlen und wo liegen die Unterschiede ?

  18. Hallo Stefan, hallo User,

    ich benutze motion schon länger mit einem Raspberry Pi2, möchte gern auf Pi3 umstellen und habe jetzt diesen Beitrag gefunden. Die Installation war soweit auch erfolgreich, wollte einige einstellungen jedoch über „putty“ vornehmen, kann mich aber nicht einloggen. Nach Login: „pi“ kommt:“Welcome to meye -a8386…“, aber dann komme ich nicht weiter. Wäre nett, wenn mir jemand das Passwort mitteilen könnte.

    Vielen Dank

    Manuel

  19. Hallo Manuel,

    schau dir mal den FAQ-Eintrag „Command Line & Shell Access“ (https://github.com/ccrisan/motioneyeos/wiki/FAQ#how-can-i-log-in-on-sshtty-console), vielleicht hilft dir der weiter.

    Grüße

    Stefan

  20. Hallo,

    Ich habe hier das 1.mal von Motioneye gehört…..und gefunden was ich schon lange suche.Leider hänge ich nun an meiner Aussenkamera,es ist eine Foscam
    Fi9900p.Die bekomme ich nicht verbunden,wenn ich sie über die Option Netzwerk Kamera einbinden will.
    Es liegt an der Netzwerkadresse so wie ich es sehe,weil Motion sagt diese Kamera wird nicht supportet????Kann das den sein???

    Die Netzwerkaddi sieht bei mir so aus

    http://meine-dns:mein-Port.

    Pw und user stimmen da ich sie über dem Browser so erreiche.
    Wo muss ich ansetzen???

  21. Hallo,

    ich habe emotioneyeos auf einem Raspberry 3 laufen und „Motion Detection“ aktiviert.
    Das funktioniert prinzipiell sehr gut, ausser die Wolken ziehen und es ist ein Wechsel zwischen heller und dunkler, dann klappt es nicht mehr.
    Ich dachte die Funktion „Light Switch Detection“ kann diese Helligkeitswechsel korrigieren, aber egal ob ich auf 0 oder 100 Prozent stelle, die „Motion Detection“ reagiert und macht Fotos.
    Kann man „emotioneye“ auch mit einem Bewegungsmelder betreiben?
    Für was sind eigentlich die Fragezeichen die bei jedem Einstellungspunkt erscheinen?
    Für mich sieht das wie eine Hilfe aus, aber leider passiert bei mir nichts wenn ich das Fragezeichen anklicke (habe einen Mac, funktioniert nicht mit Safari und auch nicht mit Firefox). Muss ich da was extra aktivieren, damit diese Hilfe funktioniert?

    Liebe Grüße
    Roland

  22. Hallo Roland,

    das mit dem Bewegungsmelder kann ich dir leider nicht sagen.
    Vielleicht kannst du eine andere Einstellungen verwenden, um die Falschmeldungen bei Sonnenlicht oder Wolken zu reduzieren. Im Abschnitt Motiondetektion gibt es ein paar, die du ausprobieren kannst.

    Die Fragezeichen sind die Hilfe zu den Einstellungsmöglichkeiten. Wenn das bei dir nicht funktioniert, liegt das an deinem Webbrowser.

    Grüße

    Stefan

  23. Hallo Roland,
    einfach nur die Maus über die Fragezeichen fahren, dann erscheint ein kurzer Hilfetext. ( Ist aber glaube ich leider nur in English)

    Um die Wolkenbewegungen-Fotos zu vermeiden vlt. den oberen Regler reduzieren, der die Menge der Bewegung misst. Ich würde mal mit 0,5 oder 0,2 probieren.
    Das kann schon sehr gut helfen.

    Happy Weekend
    Sandman

  24. Hallo nochmal, @Roland

    was ich geschrieben habe war quatsch, ich habe gerade festgestelt, das ich die selben probleme habe wie Du. 🙁

    Ich habe die Cam nun etwas runter gebogen, damit nicht mehr so viele Wolken im Bild zu sehen sind. Vieleicht hilfts.

    Bis denn dann
    Sandman

  25. Entschuldigung, habe noch etwas gefunden:
    Bei Motiondetection Mask einschalten, dann auf editable einstellen.
    Danach hat man im Kammerabild die möglichkeit mit der Maus Bereiche auszublenden ( in deinem Fall die Wolken), die dann von der Motiondetection nicht mehr „gesehen“ werden.

    Voila. 🙂

  26. Hi
    Habe einen Pi Zero W mit Kamera laufen. Mit den Einstellungen schlage ich mich auch noch immer ‚rum.
    Was ich nicht verstehe: Nachts schalte ich den Router aus (Ökofuzzi :-)). Der Raspi Zero wird dann irgendwie abgehängt und nach dem ich den Routerr wieder eingeschaltet habe, muss ich den Zero W resetten.

    Übrigens gefällt mir der Umgangston hier. Nicht immer die dummen Kommentare wie: ’so was weiss man‘

  27. Was heisst ausgehängt bzw. resetten…?
    Wenn das heisst das der Pi aus dem Netzwerk verschwunden ist und du einen Neustart brauchst,es dann aber wieder geht!Würde ich zuerst mal das Szenario behalten nach dem neustart des Routers,und versuchen den Pi mittels Ipconfig/Ping……anzusprechen,geht das nicht kann es sein das du endweder warten musst bis der Router alle Netwerkgeräte geladen hat oder je nach Software auf dem PI die Option „auf Netzwerk warten“ aktivieren.

    Falls du motioneyeos nimmst….wirst du die Option nicht finden.

    Warte einfach mal 10min auf den Pi nach dem Neustart des Routers…..

  28. Guten Tag,

    nachdem ich jetzt selber von Motion unter Raspbian auf MotioneyeOS umgestiegen bin, läuft soweit eigentlich alles gut. Eine Sache die mich allerdings stört und da weiß ich nicht ob ich einfach nicht die richtigen Einstellungen treffe oder ob es unter MotioneyeOS nicht geht ist, dass ich bei E-Mailbenachrichtungen mit Bild immer die ganze Serie von Bildern bekomme. Dabei würde mir ein einziges Bild schon ausreichen.
    Kann man das in irgendeiner Form beeinflussen? ich habe schonmal umgestellt auf Motion Triggerd (One Picture) allerdings erhalte ich dann nurnoch Notifications ohne Bild im Anhang.
    Für jede hilreiche Antwort bin ich dankbar.

  29. Hallo zusammen,

    ich bin ja von dem System euch schwer begeistert, es klappt alles soweit super. Allerdings wäre es schon hilfreich das ganze auch in Deutsch zu lesen. Gibt es irgendeine Möglichkeit das System auf deutsch umzustellen??

    Gruß
    Marcus

  30. Hallo Marcus,

    meines Wissens nach gibt es nur eine Version in Englisch.

    Grüße

    Stefan

  31. Hallo,

    habe heute auch mal MotioneyeOS in Betrieb genommen und eine günstige China Raspberry Kamera installiert. Von der Qualität der Aufnahme, der FPS und der Verzögerung bis das aktuelle Bild angezeigt wird (z.B. wenn ich winke dauert es bis zu 5 Sekunden bis dies auf dem Bildschirm erscheint!) bin ich doch sehr enttäuscht. Nutze einen Raspberry Pi1 (oder ist es ein 2? muss nochmal genau nachschauen). Ist der vielleicht zu schwach?

  32. Hallo Anton,

    Vielleicht hilft es dir, wenn du die Qualität des Streams noch ein wenig runter drehst.

  33. Hey,

    mein Problemchen ist folgendes,ich erreiche den Raspberry extern nur über den User Account.
    So sehe ich lediglich die Cam 1,die an den Raspberry (a) angeschlossen ist.

    Als Admin komme ich da von extern nicht rein,da ich aber noch 2 weitere Cams laufen habe (b+c) wäre es so besser da ich sie in der Übersicht direkt sehe.

    Gehe ich über das interne Netzwerk,klappt alles.
    a,b,c einzeln,bei a habe ich b+c als weitere Cams hinzugefügt,so sehe ich dann a+b+c in der übersicht.Woran kann das liegen!komme ich extern via DNS nicht als Admin rein,sondern nur als User!

  34. Hi Markus,

    Der Zugriff von Extern hat eigentlich nichts mit motioneyeos zu tun. Du musst auf deinem Router die Einstellungen so vornehmen, dass du auf die Weboberfläche kommst. (Portfreigabe)

    Du solltest aber aufpassen, dass deine Verbindung verschlüsselt ist!

    Grüße

    Stefan

  35. Hey schon mal Danke,

    Portfreigabe und sonst auch alles steht ja,sonst würde ich nicht als User draufkommen.
    Bei der Anmeldung User /PW kann ich mich aber nicht auf der Adminebene anmelden.

    Es wird wiederholt der Benutzer und PW von Motion Stream Security Accses verlangt.
    In den Einstellung kann man ja eine Admin Account und eien User vergeben.Das habe ich auch,als User=Bildsehen klappt es,aber über den Admin=Einstellungen verändern wiederholt sich die PW abfrage.Intern im Netzwer geht das aber…klar nicht über die DNS sondern interne IP.

  36. Hallo,
    mein Anliegen hat sich erledigt,nach dem ich das Image neu aufgespielt habe kann ich nun alles Bedienen.
    Danke für die Anregung.

    Ps.Super Anleitung und sehr verständlich ausgeführt.

  37. Hallo Stefan,ich habe mit einem Raspberry 3 B und und MotionEyeOS ein Überwachungssystem für meinen Außenbereich gebaut. Vorweg, meine Englisch ist eher rudimentär. Um nicht wieder bei Adam und Eva zu beginnen, die Hardware funktioniert mit Einschränkungen, dazu später Mehr. Die Software habe ich nach meinen Vorstellungen eingestellt, wobei die Einstellungen für „Motion Dedection“ sehr problematisch ist. Ich habe zum Testen „1 %“ genommen. Leider funktioniert die Geschichte mit dieser Einstellung nicht zufriedenstellend und schärfere Einstellungen führen dazu, dass jeder Strauch und Baum  eine Reaktion auslöst.Die Einschränkungen bei der Hardware zeigen sich deutlich bei hoher Last durch Auflösung und Frame Rate. Hinzu kommt noch, das der PI in einem Gehäuse, wegen Witterungsschutz, sitzt und auch noch der Sonneneinstrahlung ausgesetzt ist. Nach meiner Meinung überhitzt der PI 3 B und stellt seinen Betrieb ein. Unter diesen Bedingungen ist der Pi nicht mehr über die IP erreichbar, erst nach einer Abkühlungspause kann ich ihn wieder erneut starten. Gibt es dazu hier Erfahrungen?  Außerdem habe lasse ich mir bei jedem Ereignis eine Mail zusenden. Auch hier gibt es ein großes Problem. Obwohl Ereignisse aufgezeichnet werden, wiord keine Mail mit Anhang versendet. Ein Beispiel: bedeutendes Ereignis mit 15 Bildern und zwei Videos von jeweils 10 sec. um 23:45 löst den Mail-Versandt nicht aus. 8 Std. später werde ich gegen 7:30 mit neuesten Ereignissen überschüttet.Gibt es dafür eine Erklärung oder ist die Erklärung auch ein thermisches Problem. Ich wäre sehr dankbar für eine Beantwortung und einigen erklärenden Worten.Dank und herzlichen GrußJosef

  38. Hallo Josef,

    Das mit der Temperatur ist ja kein Problem des Pis oder von motioneyeos, sondern ein Problem deines Standorts. Kannst du deinen Pi nicht irgendwie beschatten?
    Ich habe bei meinen Pis gute Ergebnisse mit Kühlrippen und kleinen Ventilatoren gemacht. Die Ventilatoren kannst du auf die Kühlrippen aufkleben und an den GIPOs anschließen. In einem abgeschlossenen Gehäuse wird aber auch das wenig bringen, da die Hitze nicht nach außen abgegeben werden kann.

    Last:
    Eigentlich benötigt motioneyeos nicht so viele Ressourcen, dass der Pi damit überfordert wäre. Ich habe mal bei mir nachgeschaut. Auf einem Raspberry Pi A+ werden ca. 50% CPU benötigt. Ein Raspberry Pi Nano wird dagegen schon mit 80% CPU ausgelastet. Beide funktionieren aber sehr gut. Deine Problem mit dem verzögerten E-Mail-Versand habe ich nicht.

    E-Mail-Versand:
    Damit dein motioneyeos auch die aufgenommenen Bilder/Videos an die E-Mails anhängt, muss du das bei den Standbildern einstellen. Dazu in den Einstellungen folgendes machen “Still Images —> Capture Mode -> Motion Triggered”.

    Verzögerter E-Mail-Versand:
    Dein Problem mit dem sehr verzögerten Versand ist sehr ungewöhnlich. Es gibt eine kleine Verzögerung, bis der Pi fertig ist die Bilder zu verarbeiten, um diese dann an die E-Mail anzuhängen. Aber das der Versand mehrere Stunden später kommt, ist nicht normal.
    Du kannst ja mal schauen, ob die aufgenommenen Bilder nach der Bewegungserkennung sofort auf dem Speichermedium abgelegt werden, dass du unter dem Menüpunkt “File Storage” ausgewählt hast.

    Motion Detection:
    Du kannst noch versuchen die Bereiche, die viel Bewegung erzeugen und dein Motion dies als Bewegung erkennt auszuschließen. In den Einstellungen gehst du da zu “Motion Detection -> Mask Type —> Editable”. Anschließend kannst du auswählen, welche Bereiche bei der Bewegungserkennung ausgeschlossen werden sollen.

    Ich hoffe die Antworten helfen dir weiter.

    Grüße

    Stefan

  39. Hallo Stefan,zunächst bedanke ich mich ganz herzlich für die schnelle und ausführliche Antwort.Ich arbeite Deine Antworten mal nacheinander ab.Thermisches Problem:Mein Pi ist mit Kühlrippen ausgestattet, dass es kleine Ventilatoren zum Aufkleben gibt, war mir nicht bekannt. Mein Eindruck eines thermischen Problems ist daraus entstanden, dass ich den PI hier offen auf meinem Schreibtisch und im Schatten 48 Std. getestet habe und dabei nach dieser Laufzeit Schlieren auf den Videos, bis zur Unkenntlichkeit, entstanden sind. Das nächste Erlebnis war dann allerdings unter den Normbedingungen. Im Gehäuse  unter Sonneneinstrahlung war der PI nicht mehr über die IP erreichbar. Auch ein kurzfristiger Neustart half nicht. Erst nach einer längeren Abkühlzeit, startete der Pi wieder. Allerdings glaube ich eine Lösung für dieses Problem, auch ohne Lüfter, gefunden zu haben.Das Thema Last, empfinde ich hier anders. Deshalb habe ich auch den Verdacht, dass mein PI eine Macke hat.E-Mail-Versand:Grundsätzlich funktioniert der Versand. Die Einstellungen habe ich überprüft und sind korrekt.Verzögerter E-Mail-Versand:Hier habe ich mich wohl etwas unklar ausgedrückt. Es ist nicht so, dass der Versand von Ereignissen verspätet nachgeholt wird, sonder diese Ereignisse werden zwar aufgezeichnet, Foto und Video, aber die Mail mit Anhang wird einfach nicht gesendet. Hier das Beispiel: Ereignis: ich verlasse mein Grundstück, Mail erfolgt um 07:13 und ist korrekt. Nächstes Ereignis um 07:23 Mail wird gesendet, alles o. k.. Dann folgen Ereignisse fast stündlich über den Tag verteilt und es erfolgt kein E-Mail-Versand mehr. Erst um 17:41 wird wieder das erste Ereignis gemeldet, Mail-Versand mit Anhang. Und ab jetzt folgende. Auch nachts funktioniert die Geschichte problemlos.Mein Verdacht, auch hier handelt es sich um ein thermisches Problem, Denn die übrigen Besonderheiten fallen zeitlich mit mit dem Ausfall des Mail-Versand zusammen.In dem Zusammenhang noch die Frage, warum werden mal vier Bilder als Anhang gesendet und manchmal bis zu 10 Anhänge?Motion Dedection:Das mit dem Ausblenden habe ich versucht und funktioniert auch ganz ordentlich bei Sträuchern und Bäumen, die sich im Wind bewegen. Eine Sache die ich / man aber einfach nicht ausblenden kann, sind Licht und Schatten durch Veränderung der Wetterlage,sprich Wolken ziehen vor die Sonne und umgekehrt. Dafür habe ich, außer nach einem Kompromiss suchen, noch keine Lösung gefunden.Nun noch einmal die Frage: Ist es möglich, dass mein PI defekt ist und dadurch mit MotionEyeOS überfordert ist?Ach da wäre noch die Lösung für das Thermische Problem bei Sonneneinstrahlung. Ich werde einen ziemlich großen Brutkasten bauen und den mit ausreichenden Lüftungsschlitzen versehen, das hilft auch der Tarnung.Nun wäre ich noch für weitere Ratschläge dankbar und grüße ganz HerzlichJosef

  40. Hallo Josef,

    Das mit der Temperatur könnte schon das Problem deines Pis sein.
    Die Kühlrippen bringen nur bedingt eine Abkühlung für den Pi. Eine aktivere Kühlung in Verbindung mit einem Ventilator erzielt ein wesentlich besseres Ergebnis (Kühlrippen + Ventilator). Du kannst mal bei YouTube danach suchen, da gibt es ein paar Videos die die unterschiedlichen Kühlvarianten vergleichen.

    An deiner Stelle würde ich motioneyeos komplett neu aufspielen und den Pi mal an einem schattigen und kühlen Platz ausprobieren.
    Prüfe auch mal, ob evtl. deine SD-Karte voll funktionsfähig ist.

    Du kannst dir die Temperatur auch auf der Konsole anzeigen lassen. Logge dich dazu via SSH auf dem Raspberry Pi ein und gib den Befehl ein:

    vcgencmd measure_temp

    Der Befehl gibt dir die aktuelle Temparatur des Pis direkt aus.
    Ich hoffe das hilft dir weiter.

    Grüße

    Stefan

  41. Hallo Stefan,Deine Empfehlungen waren sehr hilfreich, dafür meinen Herzlichen Dank. Ich möchte hier kurz berichten, weil ich denke, es könnte anderen mit ähnlichen Problemen bei der Lösung helfen. Das thermische Problem habe ich weitest in den Griff bekommen. Leider ist es bei mir nicht möglich die Kombination PI / Kamera in den Schatten zu bringen. Die zu überwachende Front, ist genau südlich ausgerichtet und vollkommen frei.Abhilfe habe ich dadurch geschaffen, dass ich zur Tarnung ein Vogelhaus mit etwas größerem Volumen genommen habe. Den Boden und den oberen Teil der Rückwand habe ich mit ca 15 8 mm Löchern versehen, sodass ein Kamineffkt entsteht. Dieser Zug scheint auszureichen, um den PI zu kühlen, zumindest ist jetzt im Dauerbetrieb, 24  Std. / 7 Tage, keine Störung mehr aufgetreten. Derzeit bewegen wir uns hier am Nachmittag bei 32 ° C. Trotzdem habe ich noch einen Mini-Lüfter bestellt, den ich noch am Boden befestigen werde. Es bedarf im Augenblick nur noch einiges an Feineinstellungen, dann werde ich wohl zufrieden mein Werk betrachten können.Bleibt für mich nur noch eine  Frage übrig, kann man MotionEyeOS auch mit einer normalen, für Linux geeigneten, Webcam betreiben? Das würde alle bisherigen Probleme mit einem Schlag auflösen. Dann könnte ich die gesamte Elektronik bis auf Webcam nach innen verlagern.Nun möchte ich nochmal herzlich danken und grüßenJosef

  42. Hallo Josef,

    Vielen Dank.

    Du kannst auch andere Kameras verwenden und an ein Linux-System anschließen. Es kommt hierbei nur darauf an, ob die Treiber dafür vorhanden sind.
    Früher gab es da ein paar Probleme, wenn man Motion selbst konfiguriert hat, mittlerweile sollte es aber kein Problem mehr sein.
    motioneyeos ist der einfachste und komfortabelste Weg hierfür. Sollte das bei dir nicht funktionieren, kannst du auch Motion selbst konfigurieren und einrichten. Du findest hier im Blog auch ein paar Beiträge dazu.

    Grüße

    Stefan

  43. Hallo Stefan,ich habe das gleiche Problem, wie im ersten Post geschildert. Nach der Installation bleibt alles stehen mit „Welcome to meye-49b0ca97!
    meye-……….. login: (hier ist eine Eingabe erforderlich z.B. admin) dann kommt die
    Zeile
    Password: (hier ist eine Eingabe erforderlich z. B. Leertaste) wenn keine Eingabe
    kommt nach 60 Sekunden wieder die Login-Zeile.Wenn ich denn nun „admin“ eintippe, wird nach dem PW gefragt. Da habe ich schon alles Mögliche eingegeben: Leertaste, pi, raspberry! Ergebnis: Login incorrect.Nach Eingabe der IP im Browser erscheint tatsächlich ein Bild. Klicke ich dann das Menü (drei Striche) an, erscheint lediglich: Fit Frames Vertically

    Layout Rows
    1234

    Frame Rate Dimmer
    020406080100

    Resolution Dimmer
    120406080100Weiteres zum Einstellen erscheint leider nicht. Ich bitte um Hilfe.Horst aus Duisburg

  44. Hallo Hosrt,

    nach der ersten Installation von motioneyeos ist kein Passwort für „admin“ gesetzt. Drücke einfach die Eingabetaste und die Anmeldung sollte funktionieren.

    Siehe dazu auch die Installationsanleitung, dort steht:
    „Click on the user icon on the upper-left side of the page to switch user to administrator. Use admin with no password when asked for credentials. Feel free to explore all the available configuration options.“
    (Quelle: https://github.com/ccrisan/motioneyeos/wiki/Installation)

    Hoffe das hilft dir weiter.

    Grüße

    Stefan

  45. Hallo Stefan,herzlichen Dank für Deine schnelle Antwort. Meiner Unbegabtheit geschuldet, habe ich es nach einigen Versuchen doch geschafft. Nach Eingabe der entsprechenden IP habe ich ein Bild auf dem PC. Damit konnte ich dann auch die entsprechenden Einstellungen vornehmen.Jetzt aber noch eine Bitte um weitere Hilfestellung: An meinem Win7-PC habe ich eine USB-Camera angeschlossen, die ich mit dem Programm „webcam 7“ betreibe. Durch Einrichtung der Verbindung mit „no-ip“ kann ich von überall mit meinem Smartphone auf dieses Livebild zugreifen. Ich sehe z.B. meine Garageneinfahrt und auch alles was sich in diesem Raum bewegt.Den PC ständig laufen zu lassen, ist ja unwirtschaftlich, ja einfach teuer. Deshalbt möchte ich den gleichen Effekt jetz mit dem Raspi erzielen. Welche Einstellungen und wo muß ich da noch etwas eingeben bzw. ändern.Nochmals zur Verdeutlichung: Im Moment möchte ich kein Bild oder Video speichern, sondern lediglich  ein Livebild abrufen können.GrußHorst

  46. Hallo Horst,

    da musst du in deinem Router Portforwarding einstellen, damit du von extern auf deine Kamera zugreifen kannst. Am Pi sind keine weiteren Konfigurationen erforderlich.
    In diesem Beitrag findest du eine kurze Beschreibung dazu, wie du den Router konfigurieren musst. —> https://strobelstefan.org/?p=5827

    Hoffe das hilft dir weiter.

    Grüße

    Stefan

  47. Hallo Stefan,die Einstellung „Portforwarding“ kenne ich ja schon von meiner USB-Kamera, die ich no-ip betreibe. Nun habe ich in der FritzBox eine zweite Freigabe für die Raspi-Cam eingetragen. Im Heimnetz habe ich über Wlan nach dem Einloggen ein Bild, übers Internet bekomme ich immer nur mit Mitteilung: Server kann nicht gefunden werden,  Zeitüberschreitung. Bei meiner Wiz7-Verbindung klappt alles einwandfrei.Was habe ich ma wieder verkehrt gemacht? Kannst Du helfen?GrußHorst

  48. Hallo Horst,

    Hast du auch einen DynDNS-Dienst in deiner Fritz!Box eingetragen oder verwendest du gar eine feste IP-Adresse?

    Grüße

    Stefan

  49. Hallo Stefan, jetzt bin ich etwas irritiert. Meinen Schreiberein, meine ich, ist ja unschwer zu entnehmen,das ich bereits eine Usb-Kamera mit meinem Win7-PC mit allem Pi-Pa-Po eingerichtet habe , die auch zurfriedenstellend funktioniet. Ich gebe im Browser meine DynDNS-Adresse ein und sehe das, was die Kamera gerade aufnimmt.Ich  möchte nur nicht meinen PD 24/7 laufen lassen, sondern dafür den Pi benutzen. Ist einfach auf die Dauer wesentlich billiger.Und zur Verdeutlichung: no-ip ist meine DynDNS-Adresse. Eine feste IP habe ich natürlich nicht. Wer hat das schon?! Nur der Pi bekommt von der FritzBox immer die gleiche Adresse.Kannst Du hiermit etwas anfangen?GrußHorst

  50. Hallo Stefan,vielleicht habe ich mich nicht klar genug ausgedrückt. No-ip ist mein DynDNS-Dienst. Da ich ja bereiits eine USB-Camera über meinen Win7-PC betreibe, und ich die Bilder auch im Internet sehen kann, muß zumindest für diese Anwendung alles richtig eingetragen sein.Ich weiß nur nicht, wie ich die zweite Camera, jetzt mit dem Pi, ebenfalls abrufen kann.GrußHorst

  51. Hallo Horst,

    leider habe ich keine Erfahrung mit No-ip.
    Aber prüfe mal, ob du für deine Kamera evtl. einen eigenen Eintrag bei No-ip erstellt hast und ob du auf deiner AVM das noch eine eigene Portfreigabe für die Kamera erstellen musst.

    Grüße

    Stefan

  52. Hallo Stefan,an meinem Zero W wird eine Kamera mit OV5647-Sensor für Nachtsicht nicht erkannt, bzw. es wird kein Kamerabild angezeigt. Eine andere Kamera (Raspberry Pi Camera Rev. 1.3) funktioniert problemlos. Am RPi 3b+ wird die Nachtsichtkamera dagegen erkannt.Wo liegt mein Problem?GrüßeRüdiger

  53. Hallo Rüdiger,

    welches Betriebssystem verwendest du?
    Hast du schon mal motioneyeos angeschaut?
    Damit hatte ich bis jetzt keinerlei Probleme.

    Grüße

    Stefan

  54. Hallo Stefan,hatte ich nicht explizit erwähnt, aber ich nutzte natürlich motioneyeos entsprechend deiner Anleitung oben.GrußRüdiger

  55. Hallo Rüdiger,

    hast du nachgeschaut, ob dein Kameramodel von einem Raspberry Pi Zero unterstützt wird?
    Nicht das es hier ein Problem gibt.

    Grüße

    Stefan


Leave a comment

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Noch keine Trackbacks.

%d Bloggern gefällt das: